Sunday, March 27, 2011

Displaying the configuration on JUNOS or SRX

The configuration on a JUNOS based device can be displayed in two different formats - "JUNOS" or "set-based". Set-based means the configuration will be displayed as commands you would enter at the CLI to apply a configuration. JUNOS based displays the configuration file which you can edit at the CLI. The commands to apply are:

1. Set based:
show | display set | no-more

2. JUNOS based:
show | no-more

Upgrading Big-IP 10.2.0 1755.1 to 10.2.0 1789.0

1. Download the image or *.iso file from the F5 support site.

2. SCP to the Big-IP device and copy the iso file to the directory /shared/images

3. Apply the following command to install the Hotfix image. Note, the Hotfix image can be installed in an empty partition:

bigpipe software desired HD1.3 product BIG-IP version 10.2.0 build 1789.0

4. Configure the device to boot from the location where the new image is installed:
switchboot -b
e.g. switchboot -b HD1.3

5. Reboot the entire device. Apply the command:
full_box_reboot

Friday, March 4, 2011

Cisco Flexlinks

Cisco Flexlinks provide a layer 2 redundant link solution. It is often considered an alternate solution to Spanning-Tree protocol where STP is undesired. With Flexlinks redundant paths are manually configured by the network administrator, in comparison to STP where the redundant paths are calculated and formed dynamically by the Spanning-Tree protocol.

Advantages:
* Spanning-Tree Protocol Independant.
* No BPDUs across links.
* Fast convergence - testing shows convergence at approximately 110ms.
* Traffic can be load shared across the redundant links.
* Neighbouring switches are not affected by local network Spanning-Tree recalculations.
* Failure of an Etherchannel where STP is not running between interconnecting neighbours can cause network loops and subsequent broadcast storms.

Disadvantages
* Maximum of 16 Flexlink pairs.
* RSTP convergence can be quicker - sub-second.
* Dynamic loop prevention.
* Less administrative management.
* Etherchannel can load-balance and provide redundancy.
* Does not support load-balancing, only load sharing (allocation of VLANs per link).

Testing Scenarios:
3750 (Flexlink) -to- 3750 (STP)

TOP-SWITCH#show run int gi 1/0/21
Building configuration...

Current configuration : 351 bytes
!
interface GigabitEthernet1/0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 237
switchport mode trunk
switchport backup interface Gi1/0/23
switchport backup interface Gi1/0/23 mmu primary vlan 237
switchport backup interface Gi1/0/23 preemption mode forced
switchport backup interface Gi1/0/23 preemption delay 60
end

TOP-SWITCH#show run int gi 1/0/23
Building configuration...

Current configuration : 135 bytes
!
interface GigabitEthernet1/0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 237
switchport mode trunk
end

TOP-SWITCH#

Middle-Switch#show run int fa 2/0/45
Building configuration...

Current configuration : 156 bytes
!
interface FastEthernet2/0/45
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 237
switchport mode trunk
spanning-tree portfast
end

Middle-Switch#show run int fa 2/0/47
Building configuration...

Current configuration : 156 bytes
!
interface FastEthernet2/0/47
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 237
switchport mode trunk
spanning-tree portfast
end

Middle-Switch#

Diagnostics:
=======================
TOP-SWITCH#show interfaces switchport backup detail

Switch Backup Interface Pairs:

Active Interface Backup Interface State
------------------------------------------------------------------------
GigabitEthernet1/0/21 GigabitEthernet1/0/23 Active Up/Backup Standby


Interface Pair : Gi1/0/21, Gi1/0/23
Preemption Mode : forced
Preemption Delay : 60 seconds
Bandwidth : 100000 Kbit (Gi1/0/21), 100000 Kbit (Gi1/0/23)
Mac Address Move Update Vlan : 237

TOP-SWITCH#

TOP-SWITCH#show mac-address-table move update
Switch-ID : 033d.ae01.6210
Dst mac-address : 0120.d100.0010
Vlans/Macs supported : 1023/6272
Default/Current settings: Rcv Off/Off, Xmt Off/Off
Max packets per min : Rcv 40, Xmt 60

Rcv packet count : 0
Rcv conforming packet count : 0
Rcv invalid packet count : 0
Rcv packet count this min : 0
Rcv threshold exceed count : 0
Rcv last sequence# this min : 0
Rcv last interface : None
Rcv last src-mac-address : 0000.0000.0000
Rcv last switch-ID : 0000.0000.0000

Xmt packet count : 0
Xmt packet count this min : 0
Xmt threshold exceed count : 0
Xmt pak buf unavail cnt : 0
Xmt last interface : None
TOP-SWITCH#